All images © Bob Atkins

14.jpg

This website is hosted by:
Host Unlimited Domains on 1 Account

5.jpg

Welcome, Guest. Please login or register.

Login with username, password and session length
 
Web www.bobatkins.com
*
+  The Canon EOS and Photography Forums
|-+  Photography Forums
| |-+  Technical Questions on Photography and Optics
| | |-+  Testing Old FD Lenses
« previous next »
Pages: [1]
Print
Author Topic: Testing Old FD Lenses  (Read 4182 times)  bookmark this topic!
SidSP
Newbie
*
Posts: 12


Testing Old FD Lenses
« on: July 28, 2009, 01:16:39 PM »

Hi Bob
I’m primarily a 5DMkII and 50D shooter with a collection of decent lenses.   When traveling, hauling either camera with multiple lenses has become a problem as we are very space-constrained, so I’ve invested in an Olympus E-P1 with a pair of micro four/thirds Panasonic lenses and am very pleased so far with the portability and IQ so far. 

Now the problem…
Concurrently with my E-P1 purchase, I acquired a 25-year-old Canon AE1 Program and three lenses from a deceased uncle (Relatives: “Doesn’t he take pictures? Give it to him.”).  I successfully got into the Halliburton case and found the foam had disintegrated and was stuck to the camera and lenses.  There were three lenses that cleaned up quite well, a 17mm f/3.5 Tokina, a 70-210mm f/3.5 Vivitar, and a 28 to 85mm f/3.5-4.5 Tokina.  I figure the camera is probably a total loss—not interested in it anyway.

Since the E-P1 can be used with just about any manual focus lens with the proper adapter, including FD lenses, I would like to play with these lenses on the E-P1.  Most things seem OK on the lenses.  However, the problem may be the diaphragms. I wiggled what I thought was the diaphragm lever, but it seemed stuck on all three lenses.   Changing the aperture on the lens barrel did not move the diaphragm. The aperture appears to be wide open on all three lenses. 

Questions…
Is there some secret to changing the aperture when these lenses are not attached to a camera?  I want to test 'em before I invest in the FD adapter.

Is it likely that all three diaphragms are stuck wide open due to congealed lubricant or something?  If so, is there any reasonable way to unstick ‘em?

Is this whole thing just a waste of my time and should I simply throw everything away and move on?

Your thoughts???

Thanks for your advice.

SidSP
Logged
Bob Atkins
Administrator
Hero Member
*****
Posts: 1185


Re: Testing Old FD Lenses
« Reply #1 on: July 28, 2009, 02:42:29 PM »

FD lenes are weird and complex mechanical beasts. As I recall the apeture doesn't  change unless they are mounted on a camera. There are various levers and pins which get pushed when the lens is mounted.

You could see what happens when you mount them on the AE-1. That might allow you to confirm that they are working mechanically. You should be able to see if they stop down as they should when mounted on the camera.
Logged
SidSP
Newbie
*
Posts: 12


Re: Testing Old FD Lenses
« Reply #2 on: July 28, 2009, 03:12:39 PM »

Hi Bob
Thanks so much for your quick reply.  I mounted them on the AE-1 and used the camera DOF lever on each.  Each stopped down and then snapped back when the DOF lever was released.  I presume this means that the diaphragm is not frozen, so I've ordered the FD-->micro four thirds adapter.  It will be interesting to see how they work on the E-P1. If they work OK, I may well try to find a couple of fast primes on Adorama, BH, or KEH; the 200mm f/2.8 would be an excellent candidate, as would the 50mm f/1.4. 

Thanks again for your advice.  Once again, you were right on!

SidSP
Logged
Pages: [1]    
Print
« previous next »
Jump to: