All images © Bob Atkins

9.jpg

This website is hosted by:
Host Unlimited Domains on 1 Account

20.jpg

Welcome, Guest. Please login or register.

Login with username, password and session length
 
Web www.bobatkins.com
*
+  The Canon EOS and Photography Forums
|-+  Photography Forums
| |-+  Technical Questions on Photography and Optics
| | |-+  Canon 5DII and 500L/4.5 still has focus problem
« previous next »
Pages: 1 [2]
Print
Author Topic: Canon 5DII and 500L/4.5 still has focus problem  (Read 6538 times)  bookmark this topic!
Frank Kolwicz
Senior Member
****
Posts: 130


Re: Canon 5DII and 500L/4.5 still has focus problem
« Reply #15 on: July 17, 2012, 11:04:53 PM »

Another puzzlement: I did some shots of a very distant Great Blue Heron (maybe 300') and then a Horned Lark at about 30-40'. 25' is about the distance I setup with zero microfocus adjustment for f/8 nominal, actual focus as usual with the camera aperture at f/4.5 nominal and the 1/4x tele. The DOF for the lark was good, but the heron had focus well behind the bird. In all cases the images were made based on the focus confirmation light while manually dialing the focus ring (no Live View).

I don't know what the focus confirmation light means with this setup - with the 1.4x tele, normal phase detection AF is disabled, supposedly, but I've tape-hacked the pins to allow the camera to attempt AF and it will do so slowly if at all - like it was using contrast detection. BUT the focus confirmation light comes on fast, just like it was using normal  phase detection AF.

I also still have the tape over pins 5&6, as previously noted, since it doesn't seem to have affected anything.

If this is correct, I would have to change the microfocus adjustment to suit near or distant subjects and figure out what distance to use as the change over point. It is possible to do sometimes, as I usually am working on either small birds within 40' or larger birds more distant, but, of course sometimes the bigger birds move in real close, too, or a small bird will land nearby, if I get lucky. This is a royal pain in the ass that I've never heard of anyone having to do.

Do you know of anyone intimately familiar with the workings of these lenses who might be of help? Canon is of no use and the repair shops I know of just say bring us the lens/camera and we'll let you know if we find anything - ever.
Logged
Bob Atkins
Administrator
Hero Member
*****
Posts: 1199


Re: Canon 5DII and 500L/4.5 still has focus problem
« Reply #16 on: July 18, 2012, 12:38:03 PM »

I think you are on your own with this one. Canon are unlikely to be of help since the lens has long been discontinued and I doubt any 3rd party repair shop has the skill and knowledge to figure out what's happening in a case like this.

You said all was fine with the XTi, which suggests the lens is OK, so my inclination would be to try to get hold of another camera and run some tests. Maybe a 60D or 7D and see how that works. You could rent one if you can't come up with some other way to get hold of one. If it's the 5DII that's the issue and not the lens you may be on the wrong track. The 7D has microfocus adjust, the 60D doesn't. If there's something odd going on with microfocus, then the 60D might work (just like the XTi does) and the 7D might not. However there is no way to tell unless you try them.

I've shot quite a bit with the EF500/4L USM using a 40D and 7D and I've never noticed the issue you are describing. Then again I haven't really looked for it. I found that a Tamron 1.4x TC worked fine for AF without having to tape any pins. Center image quality was similar to that of the Canon 1.4x. The corners were a little softer.
Logged
Frank Kolwicz
Senior Member
****
Posts: 130


Re: Canon 5DII and 500L/4.5 still has focus problem
« Reply #17 on: July 18, 2012, 01:20:00 PM »

Thanks, Bob! I hope I can put this thread to rest now and just suffer with it at least until I can isolate the problem to either the camera or the lens, but I suspect that it's an interaction problem, some kind of defective communication between them.
Logged
Frank Kolwicz
Senior Member
****
Posts: 130


Re: Canon 5DII and 500L/4.5 still has focus problem
« Reply #18 on: August 01, 2012, 01:24:21 PM »

I rented a 600/4 IS and it behaves as I would expect: AF works quite well and MF feels like it is mechanically connected, rather than working electronically through the camera just like AF does with the older model 500/4.5.

In a test sequence with static subjects 14 of 16 images with AF were right on. In the field with birds, moving subjects were mostly on and standing birds were almost all critically sharp. Of 140 frames shot in the field, 48 were keepers (allowing for birds position, etc.), far better than the 10-15 I have come to expect with the 500. Of the frames that were out of focus, some were in front and some were in back of the subject, which often was moving (I wasn't using tracking AF), unlike the 500 which was focussed behind the subject 90% of the time.

So, it must be a lens problem with the 500/4.5 and I hope the shop can actually find something wrong and fix it.
Logged
Frank Kolwicz
Senior Member
****
Posts: 130


Re: Canon 5DII and 500L/4.5 still has focus problem
« Reply #19 on: August 10, 2012, 06:14:55 PM »

The firmware update solved the problem!

I'm going to put this up as a new topic in case someone who isn't watching this thread might need to see it.
Logged
Pages: 1 [2]    
Print
« previous next »
Jump to: